storm的配置以及实例实践-安装依赖

上一篇讲了jdk的安装,这一篇继续配置。在安装storm和zookeeper之前,我们需要安装一些依赖,否则在正式安装的时候会出错。安装依赖也非常简单,yum可以帮我们解决所有的问题。下面说说要安装什么依赖。

先安装c++编译器。

yum install gcc-c++

按照提示输入y,回车,安装完毕。

再安装软件包uuid-devel和libuuid-devel

yum install uuid-devel
yum install libuuid-devel

随后安装libtool

yum install libtool

安装完以上的所有,我们继续安装storm所需要的Zeromq和jzmq
zeromq下载地址:
http://download.zeromq.org/zeromq-4.1.3.tar.gz
jzmq下载地址:
https://codeload.github.com/zeromq/jzmq/zip/master

把下载的两个压缩包上传到服务器,并在服务器上解压。解压完成之后,切换到对应目录下,编译安装。

cd zeromq-4.1.3
./configure
make
make install

安装jzmq的过程也是如法炮制

cd jzmq-master
./autogen.sh
./configure
make
make install

至此,所需依赖就安装完了,下一篇,终于可以正式安装storm了。

发表评论

电子邮件地址不会被公开。 必填项已用*标注